ClevoService.exe running away with CPU...

cgilley
cgilley
I run both the fan control and the updater software.  Somewhere in the past month or so, ClevoService has decided it wants more CPU, a lot more.  When my fans go beserk, task manager shows my the culprit ClevoService at 50%+

Now I know the fan s/w wants this running, because if I kill the task, it immediately gripes and wants to restart it.  Once restarted, the task is in the background at negligible CPU.

Just an FYI.  I'm open for any suggestions, or if you need more data, just ask.   This is on a P650HS-G running Windows 10 Professional

  • OBSIDIAN PC
    OBSIDIAN PC
    cgilley said:
    I run both the fan control and the updater software.  Somewhere in the past month or so, ClevoService has decided it wants more CPU, a lot more.  When my fans go beserk, task manager shows my the culprit ClevoService at 50%+

    Now I know the fan s/w wants this running, because if I kill the task, it immediately gripes and wants to restart it.  Once restarted, the task is in the background at negligible CPU.

    Just an FYI.  I'm open for any suggestions, or if you need more data, just ask.   This is on a P650HS-G running Windows 10 Professional
    Is this still happening on the latest version of Fan Control?
  • cgilley
    cgilley
    I don't think I've seen it since an update, but I wasn't paying attention.  I'll watch for it.
  • cgilley
    cgilley
    Updated to 2.7.6 two days ago.  I immediately noticed that clevoservices thumping along at 12% - consistently.  I restored to a checkpoint before upgrading - so back to 2.7.5 - and it's now idling at .1%.

    I'm running Winows 10 Version 2004(OS Build 19041.329).
  • OBSIDIAN PC
    OBSIDIAN PC
    cgilley said:
    Updated to 2.7.6 two days ago.  I immediately noticed that clevoservices thumping along at 12% - consistently.  I restored to a checkpoint before upgrading - so back to 2.7.5 - and it's now idling at .1%.

    I'm running Winows 10 Version 2004(OS Build 19041.329).
    Are you talking about Updater 2.7.6??
    Because updater does not use ClevoService at all.
    ClevoService is part of Fan Control, and only Fan Control uses it basically...
    We havent made any change to Fan Control or ClevoService in the last year.
  • cgilley
    cgilley
    Yes, 2.7.6, I guess I just associate both applications together.  I am almost certain that the fan control prompted me for an update.  The next time I reboot, I'll update and see what happens and post results.
  • cgilley
    cgilley
    Okay, fwiw, I rebooted and am now looking at the updater wanting to upgrade as well as the Control Station.  Are these combined?  Checking fan control, I have 2.4.9 installed and the latest at 2.4.9.  So, maybe there is some logic wrong somewhere.
  • cgilley
    cgilley
    Well, went ahead and applied the upgrade.  Fan Control 2.4.9.  Update 2.7.6.  I was prompted for the updater when I rebooted - it also wanted to install the fan control.  I'd attach a screen snapshot, but my ClevoServices is idling along at 11% cpu.  This is after a reboot.  No idea what it's doing.  If there are some things I can check, I'd be happy to help debug this issue.


  • cgilley
    cgilley
    Hope everyone is well over there.  Not even a reboot resolves this issue.  My theory is that the ClevoServices isn't happy with something Microsoft has updated.  If there are any other users of FC out there, please post if you are having the same issue.
Sign In or Register to comment.
© Copyright 2016 - OBSIDIAN PC
All times are GMT