Can't boot in UEFI mode

SkuLL
SkuLL
Hello, i need some help with my UEFI/BIOS startup, since i've made a bios update a few months ago i couldn't start my pc in UEFI mode (stuck on system loading with the Obsidian logo) and can only access windows when i disable it. Eeven if try to start from a bootable USB i can't get past that same screen. i even tried to convert my SSD from MBR to GBT but i still have the same problem.. i tried disabling secure boot but then again no boot but this time i've noticed something new when booting from a bootable USB. I will attach a picture and a video to this topic, but it's always the same thing. I can't get past that system loading screen with the obsidian logo. and even if i try my default settings on the BIOS, i can't find my SSD or HDD, only the bootable USB (MBR or GPT compatible) is visible. 
I really want the UEFI boot back, since it's quicker, and more secure and can support larger hard drives.

Sign In or Register to comment.
© Copyright 2016 - OBSIDIAN PC
All times are GMT